Webcam con driver gspca su Ubuntu 8.10 Intrepid Ibex

  Ubuntu

Con l’aggiornamento ad 8.10 i possessori di webcam che usano gspca hanno riscontrato problemi risolvibili però facilmente, vediamo insieme come.

Il nuovo kernel 2.6.27 e i driver gspca entravano in conflitto ma basta aggiornare v4l alla versione 0.5.2 o successive per risolvere il problema. È possibile compilare i driver o usare i seguenti repository:

deb http://ppa.launchpad.net/lool/ubuntu intrepid main
deb-src http://ppa.launchpad.net/lool/ubuntu intrepid main

Poi basta fare l’update e il relativo upgrade e il problema è risolto.

Quello scritto sopra è il metodo semplice ma esistono altri metodi un pò più “difficili” ma più gustosi.

Uno dei metodi è quello riportato sotto.

È possibile usare module assistant, sotto il comando per installarlo

apt-get install module-assistant

Poi si scaricano i sorgenti di gspca

apt-get install gspca-source

Dopo i due passi precedenti bisogna compilare ed installare i driver, i successivi passi sono quindi

sudo m-a prepare

sudo m-a a-i gspca

Ci sono altre due operazioni da fare che sono il caricamento del driver e il rilevamento della web cam

modprobe gspca

tail -f /var/log/messages

Spero che uno dei due metodi faccia al caso vostro.

9 thoughts on - Webcam con driver gspca su Ubuntu 8.10 Intrepid Ibex

  • A me continua a non andare con nessuno dei due metodi 🙁
    Considerato anche il generale calo di prestazioni e altre regressioni, alla fine ho preferito tornare sulla ormai collaudata Hardy 8.04, che all’inizio era un macello pure lei. E questi bug erano stati segnalati già prima della release…
    Fosse stata Microsoft, apriti cielo!

  • @andrea sacchi: devi inserire quelle righe nel file /etc/apt/sources.list
    poi fai anche da shell un: sudo apt-get update
    e poi continua a seguire la procedure
    🙂

  • Apri una shell, alt+f2 e digita konsole o gnome terminal dipende se sei da kde o gnome, e digita sudo su
    inserisci la pw utente e sei “root” poi con un qualsiasi editor, vi o pico o quello che ti piace anche grafico tipo gedit, editi il file inserendo quelle righe, salvi e dai apt-get update e poi installi quello che ti serve. Snigger

  • Col primo metodo nulla di fatto: quando lancio camorama, continua a darmi l’errore “Unable to capture image.”
    Col secondo metodo, mi sono fermato al comando “sudo m-a a-i gspca” ottenendo la seguente schermata d’errore:

    dh_testdir ↑
    │ dh_testroot ▮
    │ dh_clean ▒
    │ /usr/bin/make -C /usr/src/modules/gspca clean ▒
    │ make[1]: Entering directory `/usr/src/modules/gspca’ ▒
    │ rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \ ▒
    │ .gspca.o.cmd *.o *.ko *.mod.* .[a-z]* core *.i \ ▒
    │ *.symvers *.err ▒
    │ make[1]: Leaving directory `/usr/src/modules/gspca’ ▒
    │ /usr/bin/make -f debian/rules kdist_clean kdist_config binary-modules ▒
    │ make[1]: Entering directory `/usr/src/modules/gspca’ ▒
    │ dh_testdir ▒
    │ dh_testroot ▒
    │ dh_clean ▒
    │ /usr/bin/make -C /usr/src/modules/gspca clean
    make[2]: Entering directory `/usr/src/modules/gspca’ ↑
    │ rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \ ▒
    │ .gspca.o.cmd *.o *.ko *.mod.* .[a-z]* core *.i \ ▒
    │ *.symvers *.err ▒
    │ make[2]: Leaving directory `/usr/src/modules/gspca’ ▮
    │ for templ in ; do \ ▒
    │ cp $templ `echo $templ | sed -e ‘s/_KVERS_/2.6.27-9-generic/g’` ; \ ▒
    │ done ▒
    │ for templ in `ls debian/*.modules.in` ; do \ ▒
    │ test -e ${templ%.modules.in}.backup || cp ${templ%.modules.in} ▒
    │ ${templ%.modules.in}.backup 2>/dev/null || true; \ ▒
    │ sed -e ‘s/##KVERS##/2.6.27-9-generic/g ;s/#KVERS#/2.6.27-9-generic/g ▒
    │ ; s/_KVERS_/2.6.27-9-generic/g ; s/##KDREV##/2.6.27-9.19/g ; ▒
    │ s/#KDREV#/2.6.27-9.19/g ; s/_KDREV_/2.6.27-9.19/g ‘ ▒
    │ ${templ%.modules.in}; \
    done ↑
    │ dh_testdir ▒
    │ dh_testroot ▒
    │ dh_clean -k ▒
    │ # Build the module ▒
    │ /usr/bin/make -C /usr/src/modules/gspca KERNEL_VERSION=2.6.27-9-generic ▒
    │ KERNELDIR=/usr/src/linux ▒
    │ make[2]: Entering directory `/usr/src/modules/gspca’ ▮
    │ /usr/bin/make -C /usr/src/linux SUBDIRS=/usr/src/modules/gspca CC=gcc ▒
    │ modules ▒
    │ make[3]: Entering directory `/usr/src/linux-headers-2.6.27-9-generic’ ▒
    │ CC [M] /usr/src/modules/gspca/gspca_core.o ▒
    │ /usr/src/modules/gspca/gspca_core.c:54:27: error: asm/semaphore.h: No ▒
    │ such file or directory ▒
    │ /usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_ioctl’:
    /usr/src/modules/gspca/gspca_core.c:2463: error: implicit declaration of ↑
    │ function ‘video_usercopy’ ▒
    │ /usr/src/modules/gspca/gspca_core.c: At top level: ▒
    │ /usr/src/modules/gspca/gspca_core.c:2604: error: ‘v4l_compat_ioctl32’ ▒
    │ undeclared here (not in a function) ▒
    │ /usr/src/modules/gspca/gspca_core.c:2609: error: unknown field ‘owner’ ▒
    │ specified in initializer ▒
    │ /usr/src/modules/gspca/gspca_core.c:2609: warning: initialization from ▒
    │ incompatible pointer type ▒
    │ /usr/src/modules/gspca/gspca_core.c:2611: error: unknown field ‘type’ ▒
    │ specified in initializer ▮
    │ /usr/src/modules/gspca/gspca_core.c: In function ‘spca50x_create_sysfs’: ▒
    │ /usr/src/modules/gspca/gspca_core.c:2769: error: implicit declaration of ▒
    │ function ‘video_device_create_file’ ▒
    │ /usr/src/modules/gspca/gspca_core.c:2780: error: implicit declaration of
    function ‘video_device_remove_file’ ▒
    │ /usr/src/modules/gspca/gspca_core.c: In function ‘spca5xx_probe’: ▒
    │ /usr/src/modules/gspca/gspca_core.c:4301: error: incompatible types in ▒
    │ assignment ▒
    │ make[4]: *** [/usr/src/modules/gspca/gspca_core.o] Error 1 ▒
    │ make[3]: *** [_module_/usr/src/modules/gspca] Error 2 ▒
    │ make[3]: Leaving directory `/usr/src/linux-headers-2.6.27-9-generic’ ▒
    │ make[2]: *** [default] Error 2 ▒
    │ make[2]: Leaving directory `/usr/src/modules/gspca’ ▒
    │ make[1]: *** [binary-modules] Error 2 ▒
    │ make[1]: Leaving directory `/usr/src/modules/gspca’ ▮
    │ make: *** [kdist_build] Error 2

    [email protected]:/home/iari# sudo m-a a-i gspca

    Updated infos about 1 packages
    Getting source for kernel version: 2.6.27-9-generic
    Kernel headers available in /usr/src/linux
    Creating symlink…
    Couldn’t create the /usr/src/linux symlink!
    apt-get install build-essential
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Lettura informazioni sullo stato… Fatto
    build-essential è già alla versione più recente.
    0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

    Done!
    unpack
    Extracting the package tarball, /usr/src/gspca.tar.bz2, please wait…
    “/usr/share/modass/overrides/gspca-source” build KVERS=2.6.27-9-generic KSRC=/usr/src/linux KDREV=2.6.27-9.19 kdist_image

    [email protected]:/home/iari# modprobe gspca
    FATAL: Module gspca not found.

    [email protected]:/home/iari# tail -f /var/log/messages
    Jan 25 17:26:43 ubuntu syslogd 1.5.0#2ubuntu6: restart.
    Jan 25 17:39:12 ubuntu — MARK —
    Jan 25 17:59:12 ubuntu — MARK —
    Jan 25 18:19:12 ubuntu — MARK —
    Jan 25 18:39:12 ubuntu — MARK —
    Jan 25 18:59:12 ubuntu — MARK —
    Jan 25 19:19:12 ubuntu — MARK —
    Jan 25 19:39:12 ubuntu — MARK —

  • A me non funziona comunque,
    compilando i dirver mi da l’errore al comando sudo m-a a-i gspca.

    Vi riporto una parte del messaggio:
    │ /usr/src/modules/gspca/gspca_core.c:4301: error: incompatible types in ▒
    │ assignment ▒
    │ make[4]: *** [/usr/src/modules/gspca/gspca_core.o] Error 1 ▒
    │ make[3]: *** [_module_/usr/src/modules/gspca] Error 2 ▒
    │ make[3]: Leaving directory `/usr/src/linux-headers-2.6.27-11-generic’ ▒
    │ make[2]: *** [default] Error 2 ▒
    │ make[2]: Leaving directory `/usr/src/modules/gspca’ ▒
    │ make[1]: *** [binary-modules] Error 2 ▒
    │ make[1]: Leaving directory `/usr/src/modules/gspca’ ▒
    │ make: *** [kdist_build] Error 2

    consigli?

  • Ciao, tuttoprocede fino a quando do il comando – sudo m-a a-i gspca
    durante l’operazione di building si verifica un errore, questo è il log viewer

    dh_testdir ↑
    │ dh_testroot ▮
    │ dh_clean ▒
    │ /usr/bin/make -C /usr/src/modules/gspca clean ▒
    │ make[1]: Entering directory `/usr/src/modules/gspca’ ▒
    │ rm -r -f *.o decoder/.gspcadecoder.o.cmd decoder/*.o \ ▒
    │ .gspca.o.cmd *.o *.ko *.mod.* .[a-z]* core *.i \ ▒
    │ *.symvers *.err ▒
    │ make[1]: Leaving directory `/usr/src/modules/gspca’ ▒
    │ /usr/bin/make -f debian/rules kdist_clean kdist_config binary-modules ▒
    │ make[1]: Entering directory `/usr/src/modules/gspca’ ▒
    │ dh_testdir ▒
    │ dh_testroot ▒
    │ dh_clean ▒
    │ /usr/bin/make -C /usr/src/modules/gspca clean

    se provo ad ignorare ed andare avanti digitando – modprobe gspca
    mi esce questo
    FATAL: Module gspca not found.

    Aiutooo!!!

LEAVE A COMMENT

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.