Installare KDE 4 in Mandriva 2008

  Desktop Environment, KDE

Arriva anche per gli utenti di 2008 la nostra guida per installare 4.0.0.

Abbastanza facile anche per gli utenti di Mandriva l’installazione dell’appena rilasciato desktop manager, per prima cosa è necessario aggiungere tra le sorgenti di urpmi quella necessaria per KDE 4, è possibile eseguendo da terminale il comando:

urpmi.addmedia kde4 ftp://ftp.kde.org/pub/kde/stable/latest/Mandriva/2008.0/RPMS/i586 with media_info/hdlist.cz

la procedura potrebbe essere un pò lunga, siate pazienti e attendete. A questo punto si può avviare l’installazione digitando:

urpmi kdebase4 kdeartwork4 kdeedu4 kdegames4 kdegraphics4 kdemultimedia4 kdenetwork4 kdeutils4

A questo punto il nuovo ambiente dovrebbe essere disponibili tra le sessioni al momento del login.

Non ho avuto modo di provare e sarebbe gradita conferma dagli utenti di Mandriva. Testate e commentate!

[via Esalando Prassi]

37 thoughts on - Installare KDE 4 in Mandriva 2008

  • Installare KDE 4.0.0 in Mandriva 2008 con due semplici comandi

    Arriva anche per gli utenti di Mandriva 2008 la nostra guida per installare KDE 4.0.0, facilmente e senza sforzi!

  • 🙂

    Grazie per la citazione!

    urpmi task-kde4 a me causa problemi perche’ cerca di installare pacchetti della versione alpha, inclusi in Mandriva 2008.0 sin dalla data del rilascio.

    Ciao!

  • Premetto che sono un neolinux ma ho installato i pacchetti (per un totale di 129) e alla fine anche riavviando il pc non mi cambia niente.

    Consigli???

  • Nel login manager (quello dove inserisco nome utente e password giusto?) mi compare solo KDE senza indicare il numero. Di conseguenza mi carica il 3.5.
    Sbaglio qualcosa?
    Grazie per l’aiuto 😉

  • Salve anche io come Marco ho lo stesso problema 🙁
    Ho installato tutti i pacchetti urpmi ma alla sezione del login non vedo kde4

  • urpmi kdebase4 kdeartwork4 kdeedu4 kdegames4 kdegraphics4 kdemultimedia4 kdenetwork4 kdeutils4
    Per soddisfare le dipendenze di “devel(libstdc++)” serve uno dei seguenti pacchetti:
    1- libstdc++-devel-4.2.2-0.RC.1mdv2008.0.i586: Header files and libraries for C++ development (da installare)
    2- libstdc++5-devel-3.3.6-3mdk.i586: Header files and libraries for C++ development (da installare)
    Quale scegli? (1-2) 1
    Per soddisfare le dipendenze di “devel(libgcc_s)” serve uno dei seguenti pacchetti:
    1- gcc-4.2.2-0.RC.1mdv2008.0.i586: GNU Compiler Collection (da installare)
    2- gcc3.3-3.3.6-3mdk.i586: GNU Compiler Collection (da installare)
    Quale scegli? (1-2) 1
    Uno dei pacchetti richiesti non può essere installato:
    kde4-macros-4.0.0-1mdv2008.0.noarch (perché non è soddisfatto cmake[>= 2.5.0])
    Continuo comunque l’istallazione? (S/n)

    Secondo me c’è qualche problema durante l’installazione….

  • @Marco: dal messaggio che hai messo credo dipenda da cmake, prova ad aggiornarlo con urpmi cmake e poi rifai l’installazione di kde.
    In ogni caso lunedì vedo se riesco a mettere mandriva in una VM e lo testo

  • Ora mi è comparso kde4. Solo che ha alcuni bug, lo sfondo è bianco e mi sembra non rispondere in modo corretto ai comandi. In più è in inglese.
    E’ normale?

  • si grosso modo gli stessi problemi che sta dando a me lo sfondo bianco puoi risolverlo ora nn ricordo piu come avevo fatto, per quanto riguarda altri bug come il nn avviarsi di amarok o altri problemi nn so ancora come si risolvano 🙂

  • Ciau a tutti..a me da qst errore invece:
    Alcuni dei pacchetti richiesti non possono essere installati:
    kde4-krdc-4.0.0-1mdv2008.0.i586 (perché non è soddisfatto libvncclient.so.0)
    kdebase4-runtime-4.0.0-1mdv2008.0.i586 (perché non è soddisfatto kdelibs4-core)
    kdeedu4-core-4.0.0-1mdv2008.0.i586 (perché non è soddisfatto kdelibs4-core)
    kdegraphics4-core-4.0.0-1mdv2008.0.i586 (perché non è soddisfatto kdelibs4-core)
    kdeutils4-core-4.0.0-1mdv2008.0.i586 (perché non è soddisfatto kdelibs4-core)
    libsoprano4-2.0.0-0.758303.2mdv2008.0.i586 (perché non è soddisfatto librdf.so.0)
    ..da cosa puo dipendere??ciauuz… 🙁

  • Uff! ?
    non mi pare che nel post originale si faccia riferimento a cmake…
    cmq io ho provato ad installare tutto KDE4, come indicato, dipendenze (risolte) comprese… ma alla login KDM non mi assolutamente vedere KDE4 tra le opzioni!!!
    perché
    p

  • @paolo e @Marco: nel post originale deice: “Risoluzione problemi
    Se il vostro sfondo e’ bianco cliccate sul desktop con il pulsante destro, selezionate Configure background, scegliete quello che piu’ vi piace e poi cliccate sul pulsante Apply ripetutamente, finche’ il Desktop non viene ridisegnato.”

    @Confe: prova a fare urpmi kdelibs4 e vedi che succede dopo provando nuovamente l’installazione

  • @paolo
    Uff!

    Inizialmente cmake non era disponibile e bisognava scaricarlo da cooker, ma poi ho cambiato il post, come puoi leggere nei commenti del mio sito, perche’ Helio Castro ha inserito nel repositorio il pacchetto aggiornato.

    Ho pure cambiato il comando urpmi. Il post e’ stato scritto dopo aver installato kde4 sul mio portatile e aggiornato quando sono venuto a conoscenza di problemi. Certo che se la gente li segnalasse direttamente a me sarebbe meglio!

    Ma tant’e’…

  • @Lobotomia : se faccio urpmi kdelibs4 mi dice :
    Nessun pacchetto denominato kdelibs4
    I seguenti pacchetti contengono kdelibs4:
    kdelibs4-apidoc
    kdelibs4-core
    kdelibs4-debug
    kdelibs4-devel

    ..provando a fare urpmi kdelibs4-core mi dice invece : Uno dei pacchetti richiesti non può essere installato:
    libsoprano4-2.0.0-0.758303.2mdv2008.0.i586 (perché non è soddisfatto librdf.so.0)

  • @Confe: si dovrebbe essere kdelibs4-core, ma richiede libsoprano4 che non installa perchè non soddisfa librsdf che se non erro fa parte del pacchetto redland.
    In ogni caso prima di installare le kdelibs prova a dare:
    urpmi gcc-c++ cmake libxml2-devel libbzip2_1-devel libclucene0-devel liblrdf2-devel libmesagl1-devel subversion doxygen libdbus-1_3-devel libopenssl0.9.8-devel libalsa2-devel

    fammi sapere

  • @Lobotomia: avevo gia provato..ma esce :
    Nessun pacchetto denominato libbzip2_1-devel
    Nessun pacchetto denominato libclucene0-devel
    Nessun pacchetto denominato liblrdf2-devel

    x il pacchetto redland avevo gia cercato ma nn sono riuscito a trovare nulla!…puo dipende dai repositoy? ..(se ho detto una ca***a chiedo scusa.. 😛 sn abbastanza niubbo 😛 )

  • @Confe: purtroppo non ho ancora avuto modo di provare su Mandriva, potrebbe dipendere dai repository, tu oltre quelli standard e quelli dell’articolo ne hai altri?

  • Ho aggiornato a Mandriva2008 con i repo easy urpmi.
    Tutto bene, anzi devo dire che mai mi sarei aspettato che questa distribuzione si sarebbe aggiornata senza lasciare un conflitto, un pacchetto impossibile da installare o rimuovere.
    Ho aggiunto il repo kde4 con:
    urpmi.addmedia kde4 ftp://ftp.kde.org/pub/kde/stable/latest/Mandriva/2008.0/RPMS/i586 with media_info/hdlist.cz

    ho installato con
    rpmi kdebase4 kdeartwork4 kdeedu4 kdegames4 kdegraphics4 kdemultimedia4 kdenetwork4 kdeutils4

    e anche
    kdelibs4-apidoc kdelibs4-core kdelibs4-debug kdelibs4-devel che ha installato qt4 con tanto impiego di tempo e spazio

    MA ancora NON compare kde4 nel login manager.
    Sto cercando eventuali pacchetti essenziali non installati, ma i comandi che ho dato sono stati eseguiti tutti senza eccezioni o warnings

  • @LAj: sicuro che riavviando il server X non ti esca nelle sessioni una denominata KDE4?

    Io ho fatto un test giusto ieri e a me da installazione pulita è andato tutto liscio

  • Purtroppo si,
    c’ho guardato più volte
    ma niente
    ne ho tanti installati per un totale di 9 voci
    Non penso KDM ha problemi di spazio

  • [[email protected] ~]$ ls /usr/bin/start*
    /usr/bin/startevilwm* /usr/bin/startkde* /usr/bin/startx*
    /usr/bin/startgnome* /usr/bin/start_kdeinit*
    /usr/bin/starticewm* /usr/bin/startwindowmaker*

  • @LAj: prova a fare un:
    ls /etc/X11/wmsession.d/
    così vedi le sessioni di X avviabili.

    Al massimo possiamo fare la prova di installare dal cooker nel seguente modo:

    da terminale esegui
    urpmi.addmedia main–cooker ftp://bo.mirror.garr.it/mirrors/Mandrake/devel/cooker/i586/media/main/release with media_info/hdlist.cz
    urpmi.addmedia contrib–cooker ftp://bo.mirror.garr.it/mirrors/Mandrake/devel/cooker/i586/media/contrib/release with media_info/hdlist.cz

    poi sempre da terminale esegui
    urpmi kdebase4 kdeartwork4 kdeedu4 kdegames4 kdegraphics4 kdemultimedia4 kdenetwork4 kdeutils4 kdebase4-workspace

    fammi sapere dopo installato se cambio qualcosa.

    P.s. in questo modo abiliti il cooker di sviluppo quindi dopo conviene rimuoverlo dai repository.

    Attendo notizie

  • Secondo me non ti conviene sporcare un sistema stabile con Cooker…
    In ogni caso fai come preferisci.
    kde4 e’ ora disponibile nei backports di 2008.0!
    Avreste letto il post originale lo sapreste…

  • Ci sono arrivato con molte acrobazie:
    prima il repo backend poi di nuovo kde con la 4.0.0
    Parecchi pacchetti installati e rimossi manualmente.

    Niente cooker per ora.
    Grazie.

  • A me una volta effettuato il login inizia a caricare i volumi, la grafica ecc.

    Poi tutto va in crash e torna al login. Che può esse??

    Aiutoooo! Grazie,

    Az

  • Ah sul registro dmesg, le ultime righe mi suonano strane e nefaste

    bootsplash: status on console 5 changed to on
    lp: driver loaded but no devices found
    ppdev: user-space parallel port driver
    Clocksource tsc unstable (delta = -75228291 ns)

    Grazie ancora

LEAVE A COMMENT

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.